How to create a WordPress theme from scratch

by Small Potato of Wpdesigner.com
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Part 1 - How to Design a WordPress Theme

Following this part of my book is optional because the design is very simple. This part simply shows
you what the design process looks like. Whether to follow it is up to you.

TOOLS: You'll need to install Photoshop or Gimp. I will be using Photoshop version 7.0.
If you mess up during any of the follow steps, simply go to Edit > Undo. For support, visit

http://www.wpdesigner.com/forums/ . Sign up for an account, wait for the confirmation email. (It
might be in the junk mail folder.)

Included with this part of the tutorial are screenshots taken while I was writing the following
instructions. They're in the “screenshots” folder. Start with 001.png.

Step 1: Open Photoshop. Start a new file. Use the following guidelines:

e Preset Sizes: Custom
e Width: 990 pixels
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Height: 3000 pixels

Resolution: 72 pixels/inch

Mode: RGB color

Contents: Transparent

Go to File > Save or File > Save as... (I named it “wrath.”)

Explanation(s):

e Creating a new file is like creating a new canvas.

Width 990 pixels and Height 3000 pixels are how wide and long your canvas is going to be.

e 72 pixels/inch for Resolution actually means 72 dots per inch (dpi). One dot on your computer
screen equals one pixel. 72 is for website images. (300 is ideal for printing images.)

e RGB is Red, Green, and Blue. No yellow. That's the language of computers.

e Trasparent contents basically means we'll start from scratch with this new canvas, no prefilled
background color, nothing.

Result(s):

e A toolbard, some boxes, one of them is labeled Layers. To keep your workstation clean and
simple, you may close all boxes other than Layers by clicking on the X button at the top right
corners of the boxes.

Step 2: Look at your toolbar. Find the two colored boxes. Click on the top box. That's the foreground
color box. Change your foreground (the top colored box) to White or #FFFFFF.

Explanation(s):

e #FFFFFF or #{ftftf is a hex code meaning white. In Photoshop and while coding, all colors have
a specific hex code.

e Hex codes range from #ftftft, #eeeeee, #dddddd, #cccccc, #bbbbbb, #aaaaaa, #999999, and
#888888, to #777777, #666666, #555555, #444444, #333333, #222222, #111111, and finally
#000000 (black).

e The first two digits represent Red. The third and fourth digits represent Green. The fifth and
sixth digits (that's right) Blue. You're getting the hang of this aren't you?

e Hence, #0000 is Red. #0000 is Green. #0000ff is Blue.What, no yellow? Calm down. #{fff00
is Yellow, a combination of Red and Green.

Step 3: While holding down Alt, press the Backspace key to fill the whole canvas with the color white.

Step 4: Step 2 and 3 were warm ups. Change your foreground to #ededed and do Alt + Backspace
again.

Result(s) and Explanation(s):

e Layer one is now filled with a light gray background color.
e While designing, your canvas will be made up of multiple layers.
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Step 5: Create a new layer. You can do that by:

e Clicking on the Create a New Layer button, located at the bottom of the Layers box.

e Or, go to Layer > New > Layer...

e Or, press and hold down Shft + Ctrl + N.

Result(s):
e You end up with two layers with the newest layer being labeled Layer 2.
Step 6:

e Your Layer 2 should be the selected layer. But to make sure Layer 2 is selected, you can do
that by clicking on Layer 2.

e At the toolbar, click on the Rectangular Marquee Tool.

e At the top, select Fixed Size as the value for Style.

e Enter 980 px for width, 3000 px for height.

e Go back to your canvas, click anywhere to make a 980 px by 3000px selection.

e Fill that selection with the color white (#{fftff)

e Now click on the same spot to deselect. If it doesn't deselect then go back to Style and select
Normal instead of Fixed Size. Now, try to click somewhere, anywhere, to deselect.

Result(s):

e px = pixel

e On Layer 2, now you have a large white rectangle that fills the entire height of the your canvas
and almost the full width too.

e You will be using the Rectangular Marquee Tool a lot.

e Instead of trying to guess where you should start and stop making the selection of the Marquee
tool, you selected Fixed Size to let Photoshop do it for you. All you had to do was press down
to make a perfect 980 x 3000 selection.

e 980 px is the overall width of the design. Usually, you have to figure out what the overall width
of the design or layout is going to be, before designing. Since I previously created the design for
this tutorial, I already know what the overall width size would be.

Step 7: Centering the white rectangle. This step requires the help of Layer 1.

e Click on Layer 1

e Click on the empty space next to the Layer 2 eye icon (linking the layers together).

e (o to Layer > Align Linked > Horizontal Centers

e Unlink the layers by clicking on the Layer 2 link

e Now click on Layer 2 to select it.

Result(s) and Explanation(s):
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Step 8:

Your rectangle is now centered. Although this step isn't really necessary, it's best to stay
organized. Also, now you have a balanced canvas to work on.

Create 980 by 5 pixel black border at the top

Create a new layer, Layer 3. Notice: If you had Layer 1 selected, the newly created Layer 3
would show up on top of Layer 1 instead of on top of Layer 2. Sometimes layers will get out of
order, but you can always click and hold on a certain layer to move it in order to reorganize.
Change the foreground to #000000 (black)

Select the Rectangular Marquee Tool

Change Fixed Size values to Width = 980 px, Height = 5px

Go back to the canvas and click anywhere to make the selection

Fill that selection with the color black

Switch back to Normal from Fixed Size. Now click anywhere on the canvas to deselect.
Click on Layer 2 to select it

Link it to Layer 3

Go to Layer > Align Linked > Horizontal Centers

Next, go to Layer > Align Linked > Top Edges

Unlink Layer 2 and Layer 3

Click on Layer 3 to select it

Result(s) and Explanation(s):

You should now have a 980 px by 5 px black border on top of the white rectangle. Unlike the
last alignment for the white rectangle on Layer 2, the alignment for the black border was a
must.

QUICK REVIEW:

Step 9:

You have 3 layers.

Layer 1 is the background, filled with the color #ededed.

Layer 2 has a white rectangle, 980 px in width and 3000 px in height.

Layer 3 has a black border, 980 px in width and 5px in height.

You've learned how to: change foreground colors, create new layers, link layers together, make
Fixed Size selections, fill selections with colors, and align elements.

Add a blog title

While Layer 3 is the selected layer, create a new layer, Layer 4

Select the Horizontal Type Tool

Make sure your type settings are Georgia, Regular, 18 pt, and None.

On Layer 4, click anywhere near the black border and start typing “Blog Title”
Click on Layer 2 (not Layer 3), link it to the Blog Title layer.

Go to Layer > Align Linked > Left Edges

Go to Layer > Align Linked > Top Edges

Now, unlink Layer 2 and Blog Title.
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e Click on the Blog Title to select it
e Sclect the Move Tool. You won't actually use it.
e Make sure the Show Bounding Box option is checked.
e With the Move Tool selected, press the down arrow button (on your keyboard) 19 times. This is
called nudging.
e Now, nudge it to the right 10 times (the right arrow button)
Result(s):
e For the first time, you have a new layer that does not have a number.
e Instead, it's labeled Blog Title, based on the text that you typed.
e On that layer, you have two words that are 14 px (pixels) away from the bottom edge of the
black border of Layer 3 and 10 px away from the left edge of the rectangle of Layer 2.
Explanation(s):
e Georgia is the font family. If you selected something else like Arial, your blog title would look
different.
e Regular is the font weight or style of the words / texts. You can use regular, bold, italic, or bold
italic together.
e Ptin 18 pt is how Photoshop measure font size. A lower or higher number will give you smaller
or bigger words / texts.
e None is another font style. You can try out Smooth to see the difference, but remember that it

doesn't work that way while coding your design. Without using advance techniques, web pages
in general cannot display Smooth words / texts.

Step 10: Add a thin border

Create a new layer. Notice, it's Layer 4 again. Yay!

Change foreground color to #ededed

Select the Single Row Marquee Tool. While clicking on the Marquee Tool button, hold it down
for the Single Row Marquee option.

With Single Row Marquee Tool and Layer 4 selected, click anywhere on the canvas to make a
very thin selection. That selection is 990 px in width and 1 px in height.

After making the selection, press Alt + Backspace to fill that selection with the #ededed color.
Switch back to the Rectangular Marquee Tool

Click anywhere on the canvas to deselect. You will see a new 1 pixel gray line.

From the Toolbar, select the Zoom Tool.

Zoom in on the gray line.

Switch to the Move Tool and nudge it up to the bottom edge of the blog title.

Now, nudge it back down 12 times.

Result(s) and Explanation(s):

A thin, gray line that covers the entire width of the canvas, on Layer 4.
You had to nudge up then back down 12 times because you need to know exactly how many
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pixels are in between... everything. Knowing the exact measurements is key.

Step 10.2: Add a horizontal menu of links

With Layer 4 selected. create a new layer, Layer 5

Change foreground color to #777777

Select the Horizontal Type Tool

Change the settings to Georgia, Regular, 14pt, and None

On Layer 5, click anywhere on the canvas to start typing.

Type whatever you want, but make sure you type at least 3 to 4 words.
Add six spaces (spacebar on keyboard) in between each word.

Click on Layer 2 and link it to the menu links layer.

Unlike the two layers.

Click on the menu links layer to select it.

Now zoom in (Zoom Tool), switch to Move Tool, and nudge it up to the bottom edge of the
gray line.

Nudge it back down 13 times.

Nudge it to the right 10 times.

Result(s) and Explanation(s):

Now you have a horizontal menu of 3 to 4 links / items that look evenly spaced.
All the nudging and spacebars in between each word are all to imitate how it's going to look
like when it gets coded.

Step 10.3: Create another thin line and place it 12 pixels under the bottom edge of the menu links

Create a new layer. Once again, it's Layer 5

Change foreground color to #ceecee

Make another Single Row Marquee selection

Press and hold Alt + Backspace to fill it with color

Switch to the Rectangular Marquee Tool. Make sure you're using Normal instead of Fixed
Size.

Click anywhere on the canvas to deselect.

Now, use the Rectangular Marquee Tool to select everything of Layer 5 that is outside of the
white rectangle. You're using the white rectangle of Layer 2 as a guide for where you should
make the selection, but you're actually still working on Layer 5.

Start near the left edge of the white rectangle. Click and drag the selection to the edge or the
canvas.

After making the selection, press the Backspace button to delete the selected area of the gray
line of Layer 5.

Go to the right edge of Layer 5 and do the same thing.

To deselect, press and hold Ctrl + D or click somehwere on the canvas while the Rectangular
Marquee Tool is selected.

Select Zoom Tool to zoom in

Switch to Move Tool
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Nudge the #ccccee gray line to the bottom edge of the menu links
Nudge it back down 12 times.

Result(s) and Explanation(s):

You have another gray line that is a little bit darker. #ccccee instead of #ededed. Notice, the
further you move away from #ffffff the darker it gets.

Unlike the last gray line, this line is 980px in width.

You had to delete the edges of this gray line because they did not match the background color of
Layer 1.

QUICK REVIEW:

You have 7 layers

Layer 1: background color #ededed

Layer 2: white rectangle

Layer 3: 980 px width, 5p x height black border at the top

Blog title layer: “Blog title”

Layer 4: 990 px width, 1 px height #ededed gray line

Menu links layer: (Your words / menu links or items here.) Even spaced links with 6 spaces or
spacebars in between each link.

Layer 5: 980px width, 1 px height #cccccc gray line

Step 11: Add another line using the color #5f0000. You should be able to do this step on your own.

Create a new layer, Layer 6

Make a Single Row Marquee selection under the last gray line

Fill it with #5f0000

Delete the edges.

Line it up under the bottom edge of the gray line if you haven't already done so

Step 11.1: Add a 980 px width-wise and 40 px height-wise #¢c0000 filled box / selection.

Create a new layer, Layer 7

Change foreground color to #c¢c0000

Select Rectangular Marquee Tool

Switch setting to Fixed Size, 980 px for width, 40 px for height

With Layer 7 selected, click anywhere on the canvas to make the selection
Press and hold Alt + Backspace to fill it with #c¢c0000

Press and hold Ctrl + D to deselect or switch from Fixed Size to Normal and then click
anywhere on the canvas to deselect.

Select the Move Tool and click on Layer 2

Link Layer 2 and Layer 7

Go to Layer > Align Linked > Left Edges

Unlike the two layers and click on Layer 7

Switch to the Move Tool

Copyright 2007 by Wpdesigner.com. All rights reserved.



http://www.wpdesigner.com/

e Press and hold down the Shift button on the keyboard and move the red box up to the bottom
edge of the #£50000 line

Result(s) and Explanation(s):
e You have one new #5f0000 line and a new 980 by 40 red box.
e Later on (during coding), the red box will be used for blog description.
e For Step 11, I made you make a 990 by 1 selection by using the Single Marquee Tool instead of
using Fixed Size (980 by 1) of the Rectangular Marquee Tool because I wanted you to learn
how to delete too, not just how to make selections and fill them with color.

Step 11.2: Add a 980 by 10 #e60000 rectangle under the red box.

With Layer 7 selected, create a new layer, Layer 8

Change foreground color to #e60000

Select the Rectangular Marquee Tool

Change setting to Fixed Size (if you haven't already), Width: 980 px, Height: 10 px

Click anywhere on the canvas to make the selection. If it's not at the right place, nudge your
selection left or right and up or down until it's right up against the bottom edge of the red box.
e Press and hold down Alt + Backspace to fill it with the #e60000 color

Result(s) and Explanation(s):

e Yet another rectangle. But this time, you learned how to nudge the selection before filling it
with color. Again, I'm trying to show you all the different ways that you can make exact
selections at the exact locations.

Step 11.3: Add another line under the 980 by 10 bright red rectangle, but this time we'll do something a
little different.

Left click on Layer 6

Now, right click on Layer 6

Select Duplicate Layer...

After duplicating it, move the Layer 6 copy above Layer 8 by clicking and dragging it above
Layer 8

With Layer 6 copy selected, switch to the Move Tool.

e (You might have to zoom in first.) Move the #5f0000 line of Layer 6 copy down, under the 980
by 10 rectangle of Layer 8.

Result(s) and Explanation(s):

e Your blog description area is now complete. You have a 980 by 1 #5f0000 at the top, followed
by a 980 by 40 red box (#cc0000), followed by a 980 by 10 bright red rectangle (#¢60000) that
is followed by another 980 by 1 #5f0000 line, which is a duplicate of the first line. During
coding, all thin lines will be borders.

Step 12: Create a 980 px by S5px black border under the blog description area. You should be able to
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EASILY do this on your own, but here's the shortcut:

Remember Step 8? Duplicate Layer 3, move the Layer 3 copy above the Layer 6 copy

Switch to the Move Tool and move the black border of Layer 3 copy under the blog description
area. Press and hold the Shift key while you're moving the black border so you don't have to
worry about align it left or right again.

Result(s) and Explanation(s):

You created a new 980 by 5 black border by duplicating Layer 3. You should now have 12
layers all together. (Remember to save periodically, if you haven't already, go to File > Save or
File > Save as...)

Step 13: Create a vertical dotted pattern

Create a new file, File > New or press and hold Ctrl + N.

The settings for the new file should be Width: 1 pixels, Height: 2 pixels. Everything else
should be the same as the first file you created.

1 by 2 is very small. You can't work with that so zoom in until you can't anymore.

Change foreground color to black, #000000.

At the Toolbar, select the Pencil Tool. Click and hold on the Brush Tool button until you get
the Pencil option.

Make sure the pencil options are set to 1, Mode: Normal, Opacity: 100%

Use the Pencil Tool to click on the top pixel to make one black dot

Go to Edit > Define Pattern...

A window will popup. Name your pattern or go with the default that it gives you. I named it
Dotted Vertical.

You can now close that new file without saving it.

Result(s) and Explanation(s):

You've created a 1 px by 2 px dotted vertical pattern which you'll use in the next steps.

Step 14: Back to the original file you were working on, separate the rest of the white rectangle space
into three columns. First column is 488 pixels wide, height doesn't matter. All you need is the width to
space the columns evenly.

With the Layer 3 copy layer selected, create a new layer, Layer 9

Select the Rectangular Marquee Tool: Fixed Size, Width: 488 px, Height: 250px (or
whatever the height you want)

Click anywhere on the canvas to make the selection

Nudge it to the left edge of the white rectangle and to the bottom edge of the second 5px black
blorder

Fill it with #cceece

Deselect
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Create a new layer, Layer 10

Make a 245 px by 250 px selection to the right of the rectangle of Layer 9. Make sure there's
one empty pixel space in between the #cccccc rectangle and your new selection.

Fill it with #cceeee

Deselect

Duplicate Layer 10
Use the Move Tool to move the rectangle of Layer 10 copy to the right. Again, make sure
there's one empty pixel in between the two rectangles.

Step 15: Use the vertical dotted pattern for the space in between the columns

Create a new layer, Layer 11

Select the Single Column Marquee Tool. Don't confuse this with the Single Row tool.

On Layer 11, with the Single Column Marquee Tool, go to the first empty one pixel space,
click on it to make a selection. Don't fill it with anything yet.

While that space is still selected, go to the top of the page and click on the Add to selection
button

Now, go to the second one pixel empty space, in between the second and third rectangle, click
on that space to add on to your selection. You should end up with two Single Column selections.
Go to Edit > Fill

A window will pop up, select the dotted vertical pattern you created earlier

Deselect. You should see two 1-pixel columns that are filled with black dots.

Click on the eyes next to layers: 9, 10, and 10 copy to hide them. All you should see now are
the two columns of black dots running up and down the whole canvas without the #ccccee
rectangles.

Switch from Add new selection... to New selection

While Layer 11 is selected, delete the excess black dots. Do this by making a selection from the
bottom edge of the 5 px black border to the top edge of the canvas, then press backspace to
delete the excess dots

Deselect

Step 15.2: Change color for the vertical dotted pattern

Click on Layer 11 while you press and hold down the Ctrl key. Two colums of selections will
show up.
Fill those selections with #ccccce

Result(s) and Explanation(s):

Now you have two columns of dotted #ccccce pattern that don't overlap the blog description,
menu links, and blog title areas.
The dotted pattern creates the illusion that the white rectangle has been divided into three
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columns.
Your main content area is 488 px in width. Your sidebars are 245 px each. Plus two 1-pixel
columns of dotted patterns, that adds up to 980 px.

Step 16: Create a horizontal dotted pattern. You should be able to do this on your own there will be no
screenshots to go along with this step.

Create a new file, File > New or Ctrl + N, Width: 2 pixels, Height: 1 pixels. Everything else
should match the first two files you created.

Zoom in so you can work with this small canvas

Change foreground color to black

Use the pencil to color the first or left pixel

Go to Edit > Define pattern..., name your pattern or go with the default it gives you

Close this pattern file without saving.

Result(s) and Explanation(s):

Adding on to your collection of patterns is a horizontal dotted pattern. Similar to the vertical
dotted pattern, when used, this pattern will skip every other pixel to make a dotted line.

Step 17: Create the background for back and forth navigation links.

With Layer 11 selected, create a new layer, Layer 12

Select the Rectangular Marquee Tool: Fixed Size, Width = 468 px, Height = 36 px

On Layer 12, click anywhere on the canvas to make the selection, preferrably near the middle
of the first column.

Change foreground to #fdfbe7

Press and hold Alt + Backspace to fill the selection with #fdfbe7

Deselect

Click on the hidden Layer 9 while holding down the Ctrl key to load its selection. But notice,
you're still working on Layer 12

Go to Select > Modify > Contract

Contract by: 10 pixels

Go to Layer > Align To Selection > Top Edges

Go to Layer > Align To Selection > Left Edges

Deselect

Result(s) and Explanation(s):

Now, the box on Layer 12 looks like it has a 10-pixel padding all around it. Again, all you're
doing is laying everything out to see what the design in your head actually looks like before you
code it. Most of this is unneccessary. However, it's a must for more complicated designs or
layouts that require lots of grahpic design.

Step 18: Add border and horizontal dotted pattern on top of the navigation links background
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e With Layer 12 selected, create a new layer, Layer 13

e Zoom in to make a 468 by 1 selection. This selection should be right on top of the first pixel of
Layer 12's rectangle. If you can't get it right, nudge your selection until it lines up to the left
edge of the rectangle and overlaps the rectangle's first top pixel.

Change foreground color to #e0dcb8

Press and hold Alt + Backspace to fill that selection with the #e0dcb8 color

Don't deselect

After filling the selection with color, nudge it down to the bottom of the rectangle.

Don't deselect

Create a new layer, Layer 14

Go to Edit > Fill, select the horizontal dotted pattern

Click on Layer 14 while you're holding down the Ctrl key. The selection will change from
selecting the whole 468 by 1 line to selecting only the black dots

e Change foreground color to #cfcba2

Step 19: Add navigation link title

With Layer 14 selected, create a new layer, Layer 15

Change foreground color to #cc0000

Select the Horizontal Type Tool

Font settings: Verdana, Regular, 12pt, and None

Click on your canvas, somwhere near the rectangle you created in Step 18
Type “Older posts”

Click on Layer 12 while you hold down the Ctrl key to load its selection
Go to Select > Modify > Contract. Contract it by 10 pixels

Go to Layer > Align To Selection > Vertical Centers

Go to Layer > Align To Selection > Left

Deselect

Result(s) and Explanation(s):
e Now you have a navigation box and link to back to “Older posts”
Step 19.2: Put layers: 12, 13, 14, and Older posts in a layerset / folder
e With the layer “Older posts” selected, click on the Create a new set icon
e Starting with the “Older posts” layer and then Layer 14 and so on...drag all the layers listed at
the beginning of this step into this new layerset / folder
e Click to the layerset folder icon, there's an arrow pointing down. Click on it to collapse the
layerset. The arrow should now point towards the folder icon.

Explanation(s):

e This step was for organization. You'll be adding on more and more layers. It's better to start
organizing now than later.
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Step 20: For the content area, create a dummy post that includes post title, date stamp, text, and author
listing, category listing, and comments number

With the Set 1 layer set selected, create a new layer, Layer 15 (again)
Change foreground color to #000000 (black)

Select the Horizontal Type Tool

Font settings: Georgia, Regular, 24 pt, and None

Click on start typing anything you want.

Click on the hidden Layer 9 while you hold down the Ctrl key to load its selection
Go to Layer > Align To Selection > Left Edges

Deselect

Switch to using the Move Tool

Nudge the text up to the bottom edge of the navigation link rectangle
Nudge it back down 20 times

Nudge it to the right 20 times

Create a new layer, it's Layer 15 again

Change the foreground color to #666666

Select the Horizontal Type Tool

Font settings: Verdana, Regular, 12pt, and None

Click and type “August 07, 2007” or another date with month, day, and year in that order
Click on the hidden Layer 9 while holding down the Ctrl key to load its selection
Go to Select > Modify > Contract. Contract by 30 pixels

Go to Layer > Align To Selection > Left Edges

Deselect

Nudge it up to the bottom edge of the post title

Nudge it back down 20 times

Create a new layer, Layer 15... again

Change foreground color to #000000

Select the Horizontal Type Tool

Font settings: Verdana, Regular, 12 pt, and None

Go to Windows > Character. A small window will pop up.

On the right column, change the second top box value to 24 pt

You can now close that window.

Click anywhere on the canvas to start typing, preferrably near to the first column. What you
want to do is stay within that column. That means estimating where you will hit the Enter key
for line breaks.

Click on the hidden Layer 9 while holding down the Ctrl key to load its selection.

Go to Layer > Align To Selection > Left Edges

Deselect

Switch to using the Move Tool, nudge your paragraphs up to the bottom edge of the date
Nudge it back down 20 times

Switch back to the Horizontal Type Tool and click anywhere on your paragraphs of texts
Go the end of the paragraphs, hit Enter twice.

Type: By admin | Posted in Uncategorized | Comments (0)
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Click and highlight “admin”

Change its color to #cc0000

Repeat those steps for “Uncategorized”
Repeat those steps for “Comments(0)”

Result(s) and Explanation(s):

e Now you have a post title, date stamp, two paragraphs of content, and the post meta area, which
was the last line that you typed.

e You changed the colors of the “admin,” “Uncategorized,” and “Comments (0),” to indicate that
they are links.

Step 21: Put all dummy post layers in a folder

e Create a new set
e Put the last three text layers into that set / folder
e Collapse that set by clicking on the arrow next to the folder icon

Step 22: Create and organize the second set of dummy post layers

Lef click on Set 2, right click on it, select Duplicate Layer Set...

Use the Move Tool to move the duplicated (second) dummy post layers to the bottom.
Nudge it up to the bottom edge of the last set of dummy post layers

Nudge it back down 40 times. 1, 2, 3,4, 5...1, 2, 3, 4, 5. That's what I do.

Result(s) and Explanation(s):
e Now you know how each blog post looks like and how multiple posts listing look like.
Step 23: Add another navigation links rectangle

Left click on Set 1, right click on it and select Duplicate Layer Set...

Left click on the duplicated layer set, drag it above the Set 2 copy set

Use the Move Tool to drag the duplicate navigation links set to the bottom
Nudge it back up to the bottom edge of the second dummy post layers
Nudge it back down 20 times

Result(s) and Explanation(s):
e Now you have two sets of navigation or back and forth links. You could even call it pagination
links. Go figure. Usually, there's only one set of navigation links, but it's better to use two sets
so users can easily move through your blog.

QUICK REVIEW:

e Now you know how to make selections, use the Move Tool, nudge, color, create layersets,
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load selections of hidden layers, and everything else you need to know. We're going to move
quickly through the last few steps to create dummy content for the two right columns / sidebars.

Step 24: Create the sidebar title background and borders

On top of Set 1 copy, create a new layer, Layer 18

Select Rectangular Marquee Tool

Settings: Fixed Size, Width: 225 px, Height: 36 px
Make selection in the second column area

Change foreground color to #{8{8f8

Alt + Backspace to fill the selection

Deselect

Click on the hidden Layer 10 while holding down the Ctrl key to load its selection
Go to Select > Modify > Contract. Contract by 10 pixels
Go to Layer > Align To Selection > Top Edges

Go to Layer > Align To Selection > Left Edges

Create a new layer, Layer 19

Zoom in and make a 225 px by 1 px selection on top of the first pixel of the rectangle of Layer
18. Note: You're still working on Layer 19.

Change foreground color to #dfdfdf and press Alt + Backspace to fill the selection

Nudge the selection down the the bottom edge of the gray rectangle

Create a new layer, Layer 20

Go to Edit > Fill. Select the horizontal dotted pattern.

Lef click on Layer 20 while holding down Ctrl to load the selection of the dotted pattern
Change foreground color to #ccccee. Alt + Backspace to fill the selection, which changes the
color of the dotted pattern

Deselect

Step 25: Add first sidebar title

Creat a new layer, Layer 21

Change foreground color to #000000

Select the Horizontal Type Tool. Font settings: Georgia, Bold, 16 pt, and None. To change
the font size to 16 pt, don't click on it for the drop down list. Click on the font size box until
you can delete the font size and type in your own.

Type “Categories”

Left click + Ctrl on Layer 18 to load its selection

Go to Select > Modify > Contract. Contract by 10 pixels

Go to Layer > Align To Selection > Vertical Centers

Layer > Align To Selection > Left Edges

Deselect

Step 26: Add dummy links list

Change foreground color to #cc0000
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Select Horizontal Type Tool. Settings: Verdana, Regular, 12 pt, None, Line height: 24 pt
Create a new layer, Layer 21 again

Click on the canvas, somewhere near the sidebar title rectangle

Start typing anything you want. You're trying to layout sidebar links. How many links and lines
is up to you. There's no need to do much. I'd go with 4 to 5 links / lines.

Left click + Ctrl on Layer 10 to load its selection

Contract by 20 pixels

Layer > Align To Selection > Left Edges

Deselect

Switch to Move Tool and nudge it down 13 times from the bottom edge of the sidebar title
background rectangle

Step 27: Create a new set and put all the sidebar layers in the that set / folder

e Click on Create a new set button
e Move all the layers in that set / folder, starting with the dummy links list layer
e Collapse that new set by clicking on the arrow next to the folder icon

Step 28: Add another sidebar block

e Left click on Set 3, right click on Set 3, and select Duplicate Layer Set...

e Use the Move Tool to move all the layers within the duplicates layer set down, under the first
sidebar block

e Nudge it down 15 times from the bottom edge of the dummy links list

Step 29: Repeat step 28
Step 30: Move the latest sidebar block to the second right column
Step 31: Add another 980px by Spx black border

e Lef click on Layer 3 copy, right click on it, and duplicate it

e Click and drag Layer 3 copy 2 to the top of the layers list, above Set 3 copy 2

e Use the Move Tool to move the new black border down to the bottom of the canvas, 10 pixels
from the bottom edge of the second navigation links area

Step 32: Add footer texts and links

Create a new layer, Layer 27

Change foreground color to #000000

Select Horizontal Type Tool. Font settings: Verdana, Regular, 11 pt, and None

Click somewhere under the last black border and start typing your footer message. I typed,
“Powered by WordPress. Theme by Wpdesigner”

Change the color of WordPress and Wpdesigner to #cc0000

e Use the Move Tool to nudge it up to the bottom edge of the black border

e Nudge it back down 20 times
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e Left click on Layer 2, link it to the footer layer
e Go to Layer > Align Linked > Horizontal Centers
e Unlinkthe two layers

Step 33: Cut off the rest of the white rectangle and dotted pattern

e With Layer 2 selected, use the Rectangular Marquee Tool. Click and drag the selection from
where the black border stops to the bottom of the canvas.

e Hit the Backspace key

Don't deselect

e Left click on Layer 11 and hit Backspace again to delete the excess vertical dotted pattern at the
bottom of the canvas

THE END
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